:::: MENU ::::

Teensy 사용하기

Teensy는 아두이노 호환 보드로 Cortex M0, M4기반의 보드가 있어서 보다 높은 프로세싱이 필요한 응용에 적합하다. 이 보드를 사용하기 위해서는 Teensyduino라는 프로그램을 설치해야 하는데, 이것은 기존 아두이노 IDE에 추가적으로 설치되는 코드들과 다운로드를 위한 프로그램이 포함되어 있다.

Teensy_USB_Development_Board_1

Teensy_USB_Development_Board

먼저 아두이노를 설치하고 https://www.pjrc.com/teensy/td_download.html 이 사이트에서 파일을 다운로드해서 설치하는데 문제는 아두이노 1.0과 아두이노 1.6.x 이 동시에 설치가 되어 있으면 아두이노 1.0쪽에만 설치가 된다.(아두이노 1.6.x쪽을 지정이 안됨) 따라서 일단 아두이노 1.0을 언인스톨하고 1.6.x에 설치를 한 후 다시 아두이노 1.0을 설치를 해야 한다. Teensy 3.2의 경우 Cortex M4이기 때문에 SPI를 사용하는 응용은 Teensy 라이브러리에서 SPI 드라이버(faster SPI library for Teensy 3.0)도 같이 설치를 해야한다. 그리고 나머지 필요한 라이브러리는 아두이노 1.6.x의 라이브러리 매니저에서 추가한다.

*코드중에 호환이 안되는 것중 하나 – isDigit ==> isdigit 으로 바뀌어야 함.


So, what do you think ?